Cache

Forums: 

Hola a todos..

No se si me puede decir cual es la mejor partición para una cache y porque..? y como optimizar la misma.

Saludos

Yo creo una particion

Imagen de damage

Yo creo una particion especifica para el squid la cual llamo /cache/.

En lo personal me ha dado mejores resultados que tenerla en /var/spool/..., no he podido nunca a ciencia cierta medir la mejora en el desempeño del cache, pero si se nota una gran diferencia al menos en equipos con recursos pobres o limitados.
Por cierto debes darle como usuario a squid a esta particion para que este la pueda usar y hacerle el swap.

chown -R squid:squid /cache/

Keep The Fire Burning.....
Stryper 1988

tengo un problema con mi

tengo un problema con mi cache y todavia no lo soluciono, ya que que cuando mis usuario pasa por la cache la paginas se pone lenta, lo que hice primeramente fue vacia la cache, y de hay funciono bien por un momento, pero otra vez vino el problema, ahorita esta funcionando bien, porque mis usuario no estan saliendo por el proxy. Y eso no es conveniente para mi.. No se como arreglarlo...

Saludos

Talvez los padres

Imagen de pepo

Puede ser que estés creando un ciclo con los padres en caso de que estés ocupando estos. Además no podrías decir que está funcionando bien si el usuario no lo usa para evitar problemas :) Debes comprender bien que es lo que esperas hacer con Squid, si un proxy transparente o un proxy acelerado (reverse proxy)

Linux User Registered #232544
Jabber :

Ekiga :

ICQ : 337889406
GnuPG-key : www.keyserver.net

------------------------------------------------
Linux User Registered #232544
Jabber :

Ekiga :

GnuPG-key : www.keyserver.net

Eso no debería pasar ya que

Imagen de damage

Eso no debería pasar ya que el cache es justo para que se almacenen sitios y esten disponibles en el server.
Lo que te recomiendo es que postees tu configuración del squid.conf, puede ser que tu proxy no este transparente y acelerado, para eso es bueno ver tu configuración.
Otra cosa adicional, estas nateando??

Keep The Fire Burning.....
Stryper 1988

a ver el mi

a ver el mi /var/log/messages no sale nada, en el /var/log/squid/access.log se ve que esta navegando:
1148935543.982 86400189 192.168.106.70 TCP_MISS/502 1283 POST http://81.177.26.21/sp/post.php - DIRECT/81.177.26.21 text/html
1148937320.313 86399924 192.168.106.70 TCP_MISS/502 1283 POST http://81.177.26.21/sp/post.php - DIRECT/81.177.26.21 text/html
1148939155.059 86399153 192.168.106.70 TCP_MISS/502 1283 POST http://81.177.26.21/sp/post.php - DIRECT/81.177.26.21 text/html

en mi /var/log/squid cache.log me sale esto:

2006/05/29 20:43:38| http://207.46.1.5/gateway/gateway.dll?SessionID=1862422761.12316
2006/05/29 21:32:24| WARNING: Closing client 192.168.107.122 connection due to lifetime timeout
2006/05/29 21:32:24| http://storage.msn.com/storageservice/schematizedstore.asmx
2006/05/29 22:59:04| WARNING: Closing client 192.168.107.122 connection due to lifetime timeout
2006/05/29 22:59:04| http://storage.msn.com/storageservice/schematizedstore.asmx

y en mi /var/log/squid/store sale:

1148973591.629 RELEASE -1 FFFFFFFF 712428E0B1E8141CC35112523CBA657D 403 1148973591 0 1148973591 text/html 1100/1332 CONNECT 205.188.158.121:25
1148981498.167 RELEASE -1 FFFFFFFF B6107F852D33459426FFEE583FCFE97C 403 1148981498 0 1148981498 text/html 1098/1330 CONNECT 61.135.132.100:25
1148981519.311 RELEASE -1 FFFFFFFF 34C6EC4F8CF21A67508E71FA8F182882 403 1148981519 0 1148981519 text/html 1098/1330 CONNECT 61.135.132.100:25

Si estoy nateando..? si lo estoy haciendo... Estoy Utlizando proxy Transparente..

Saludos

Muchas veces no es squid el culpable

Imagen de damage

Yo tuve hace algun tiempo muchos problemas con squid (yo con el, no el conmigo), pero todo se debia a que no estaba nateando bien, osea no estaba haciendo el REDIRECT con IPTABLES, y otro problema era al asignarle memoria al squid.
No estaria demàs si posteas tu nateo, verifica que tu firewall este funcionando como debe ser, que este no este denegando conexiones hacia alguna red en internet, ya que veo en un log que te sale TIMEOUT (esto me paso con mi firewall y ya le estaba hechando la culpa al proveedor :lol:, verifiquè y estaba denegando conexiones a redes privadas externas).

Trata de desactivar el manejo de memoria y mira si te da resultados, la recomendaciòn de Pepo es muy cierta, verifica eso si es aplicable en tu caso.

Keep The Fire Burning.....
Stryper 1988