Cómo instalar GNOME en nuestro CentOS

Imagen de Epe

Éste howto persigue el mismo objetivo del anterior: [url=http://www.ecualug.org/?q=2006/08/26/comos/centos/como_instalar_xfce_en_nuestro_centos]Cómo instalar XFCE en nuestro CentOS[/url]

La idea principal es: Por alguna razón nos topamos con un linux CentOS instalado con el ambiente de modo texto solamente, no tiene nada de ambiente gráfico.

Aunque esto es una seguridad adicional, el no tener toda esa cantidad de aplicaciones gráficas, hay personas que no pueden vivir sin tener el mouse, así que me decidí postear éste howto.

El GNOME es un conjunto de aplicaciones bastante grande, tomará instalar unos 212 paquetes o más para lograr nuestro objetivo, así que si lo que deseas es un peque ambiente gráfico, te sugiero el howto de XFCE.

Para ver una lista de grupos de paquetes que podemos instalar ponemos:

yum grouplist

Veremos uno de esos grupos se llama GNOME Desktop Environment, ese es el que hay que instalar:

yum groupinstall "GNOME Desktop Environment"

Según el tipo de conexión de internet tendrás que esperar un bueeeeeeeeeeeeeeen rato a que bajen las 200 y tantos paquetes... mientras tanto almuerza como haré yo ahora. Regreso cuando acabe de bajarlos....

Listo, ya almorcé, tuve que esperar aún más tiempo pero ya tengo el GNOME instalado. Veamos:

Lo que más tiempo tomó fue sin duda el bajar los paquetes de gnome y asociados, más de 2 horas me tomó en una conexión de 400kbits.

Lo primero a hacer es editar /etc/X11/xorg.conf y comentar la linea 21, que dice:

FontPath "unix/:7100"

Dejarla como:

#FontPath "unix/:7100"

Y ya: pude ejecutarlo con:

startx

No recomiendo el uso de ambientes gráficos en servidores, pero si tiene una necesidad específica, ésta sería la solución.

saludos!
epe

Comentarios

Instalando el "Gnome Desktop

Imagen de deathUser

Instalando el "Gnome Desktop Enviroment" en un server remoto con CentOS 5 me dio un error como:


Error: Missing Dependency: libgaim.so.0 is needed by package nautilus-sendto

Luego de una encomendada a San GooGle, me topé con la solución muy trivial, pero funcional:

Descargar el rpm del paquete que jode por las dependencias e instalarlo con un --nodeps y luego si proceder con el:


yum groupinstall "GNOME Desktop Environment"

Para los que no les gusta navegar buscando:


wget -c http://mirror.centos.org/centos/5/os/i386/CentOS/nautilus-sendto-0.7-5.fc6.i386.rpm ;
rpm -ivh --nodeps nautilus-sendto-0.7-5.fc6.i386.rpm;
yum groupinstall "GNOME Desktop Environment"

Espero le sea útil a alquien;

bye
:)

PD: lo de la dependencia es un bug reportado y no arreglado, ya que si se fijan la dependencia es con una librería de gaim, que ya no existe, pues ahora es pidgin

Por cierto, en el caso de

Imagen de deathUser

Por cierto, en el caso de que sea una versión de 64 bits en la que estén instalando, necesitarán el paquete nautilus-send-to para 64 bits, si no no les va a funcionar (ya me pasó :D)

Para que copien y peguen:


wget -c \
http://mirror.centos.org/centos/5.2/os/x86_64/CentOS/nautilus-sendto-0.7-5.fc6.x86_64.rpm;
rpm -ivh --nodeps nautilus-sendto-0.7-5.fc6.x86_64.rpm;
yum groupinstall "GNOME Desktop Environment"

Happy Hacking ...!!!
:)

es para evitar que se

Imagen de Epe

es para evitar que se conecte al servidor xfs, pero si quieres levanta el servicio xfs y prueba.. nos comentas si no te da problema (el problema es bien visible: no funciona nada)...

Saludos
epe
--
NuestroServer.com
Ecuador: +(593) 9 9246504, +(593) 2 600 4454
USA: +1 305 359 4495


Saludos
epe

EcuaLinux.com

+(593) 9 9924 6504

Servicios en Software Libre

servidor xfs

Imagen de sxavyer

una vez que instale el GNOME Desktop Environment y luego startx seguia sin tener acceso a mi entorno grafico, me salia un error de que el servidor X no esta en el path especificado, resulto ser que no tenia instalado el grupo correspondiete a X server, lo instale con

yum groupinstall "X Window System", luego puse startx y listo mi entorno grafico volvio! al fin!! despues de unos dos dias q me pase viendo como recuperarlo antes de formatear todo de nuevo.

Con respecto a /etc/X11/xorg.conf y la línea q me dices, en mi archivo no tengo esa línea, yo no hice nada con respecto a ese paso q mencionas pero igual mi GNOME ya funciona, yo trabajo con CENTOS 5.

Estaba leyendo q El servidor X se conecta al servidor xfs pero la no tengo claro q es el xfs o si es lo mismo q el servidor X.

Saludos!!

Att.

Xavier !!!