Como instalar bcm43xx y WiFi-Radar en Debian GNU/Linux

Imagen de ElSanto

Tema: 

Despues de haber escrito ya varios años atras de como configurar tu BCM4318 en GNU/Linux en x86-64 usando el ndiswrapper, y gracias a la gente que esta realizando un gran trabajo de ingenieria inversa con los drivers para Broadcom ya lo tenemos incluidos estos driver en el kernel a partir del kernel 2.6.17-rc2 ;) por lo cual el proceso de instalación es más sencillo, tambien vamos a ver como hacer para que nuestro Debian nos busquen y nos conecte a la red wireless automaticamente dependiendo del lugar donde nos encontremos sin estar configurando a cada rato ;) para esto usamos WiFi-Radar

Comencemos con el bcm43xx, en algunos lugares se dice que hay problema con este driver pero eso debe ser anteriormente, porque a mi me esta funcionando de maravilla en mi debian Etch en una HP zv6000 amd64, hace un par de semanas atras comence a bajar la ultima imagen semanal de Debian-installer, para asegurarme de tener lo ultimo de los driver del hardware más nuevo ;)

Con esta imagen empece la instalación y comence a escribir el articulo de como pasar de windows a Debian GNU/Linux Parte I ;) asi que una vez finalizado el proceso de instalación podemos ver si el kernel detecto el driver, asi que tenemos que poner lo siguiente


$ lspci

en la salida hemos de tener algo parecida a esto

03:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

Si en el caso de que nos saliera: command not found, entonces tu necesitas instalar pciutils

# aptitude install pciutils

La gente tiende a confundir acerca del driver bcm43xx que viene en Debian Etch, creen que, porque ya el kernel lo ha reconocido ya deveria funcionar y no es asi uds pueden correr

$ dmesg

y veran errores o problemas relativos a wireless porque no funciona, eso es debido a que necesita el firmware que es necesario para el hardware, asi que debemos instalarlo primero ;)

Antes vamos a instalar unos pre-requisitos ;)

aptitude install module-assistant build-essential

ahora con un simple

aptitude install bcm43xx-fwcutter

Reiniciamos la computadora y ya tenemos listo para configurar la red wireless asi que nos vamos a Escritorio->Administración->Red y selecionamos la interface wireless y presionamos el boton Propiedades y comenzamos a poner los datos de nuestra red wireless

[flickr-photo:id=450576498,size=o]
Presionamos Aceptar y despues de uno dos minutos aproximadamente ya la tenemos activada y lista para navegar ;)
[flickr-photo:id=452163196,size=o]
[flickr-photo:id=450576490,size=o]

WiFi-Radar

WiFi-Radar es una utilidad que te permite explorar las redes wireless disponibles y crear los perfiles para tus redes preferidas. Ahora para instalar Wifi-Radar tenemos que poner lo siguiente


# aptitude install wifi-radar

despues lo corremos

# wifi-radar

Si en el caso de tengamos el siguiente mensaje:

eth2 Interface doesn't support scanning.

eth2 no wireless extensions.

no se preocupe, es que tenemos que reconfigurar el WiFi-Radar para que trabaje con la interface de red adecuada, primero debemos saber cual es poniendo el siguiente comando nos mostrara cual es

# iwconfig

Obtenemos una salida como esta (los datos fueron cambiados asi que no traten de conectarse los que viven cerca de mi casa)

lo no wireless extensions.

eth2 no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11b/g ESSID:"dd-wrt" Nickname:"Broadcom 4318"
Mode:Managed Frequency=2.437 GHz Access Point: 00:6F:62:D2:AF:12
Bit Rate=11 Mb/s Tx-Power=18 dBm
RTS thr:off Fragment thr:off
Encryption key:EA29-59FC-924A-322F-03AE-3F29-43 Security mode:open
Link Quality=100/100 Signal level=3/3 Noise level=186/100
Rx invalid nwid:0 Rx invalid crypt:5 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

Ahora sabemos que es eth1 en mi caso ;) entonces tenemos que reconfigurarla ya que WiFi-Radar esta trabajando con eth2, asi que ponemos lo siguiente:


# dpkg-reconfigure -p low wifi-radar

nos va a salir una ventana como la siguiente en donde debemos tipear la interface correcta
[flickr-photo:id=450518577,size=o]
una vez realizado esto corremos denuevo WiFi-Radar

# wifi-radar

y üalà ya nos muestra todas las redes wireless que estan a nuestro alcance ;) asi que debemos configurar el perfil de aquellas que son nuestras ;)

[flickr-photo:id=450518579,size=o]

Selecionamos la primera y ponemos conectar, como no la hemos configurada nos preguntanra si deseamos configurarla,le ponemos que si
[flickr-photo:id=452186947,size=o]

[flickr-photo:id=452163198,size=o]

[flickr-photo:id=452163204,size=o]

[flickr-photo:id=452163212,size=o]

[flickr-photo:id=452163208,size=o]

[flickr-photo:id=452163216,size=o]
Una vez que ya tenemos configuradas las redes wireless que tenemos en la casa y las que tenemos en el trabajo, entonces con tan solo poner el siguiente comando nos conectaremos con la primera que este disponible ;)

# wifi-radar -d

Para los que no desean estar tipeado cada vez esto, lo podemos poner en tiempo de booteo /etc/init.d/wifi-radar ;) y asi cada vez que prendamos nuestro computadora comience a buscar y conectarse a la primera que encuentre y que este configurada en wifi-radar

Ahora les recomiendo que instalen wpa_supplicant para tener soporte de WPA y WPA2 y lo configures con wifi-radar, pero eso se los dejo de tarea ;)

Espero que les ayude un poco este pequeño como :)

Comentarios

¿porque me pasa esto cuando intento encriptar con wap?

he instalado wifi radar y funciona bien pero no soy capaz de encriptarlo
he estado haciendo pruebas y no termina de arrancar
en el interfaz del router:
none
wep
802.1x
wpa-psk >probe este con tkip y aes.
wpa
wpa2-psk(aes) > probe este
wpa2(aes)
wpa-psk/wpa2-psk > y probe con este tambien

luego en el interfaz del wifi radar:

Network name - DESCONECTADO
wifi Options
mode - auto >me han consejado que pusiera auto
channel - auto
key - aqui puse la clave que genera el wpa_passphrase "ssid" "passphrase" y no me deja poner toda la parrafada, deja poner menos de la mitad, asi que supongo que será lo mismo que pongo en el interfaz del router
security- en blanco
use WPA
driver - puse ndiswrapper ya que lo uso para el driver de mi wifi y me dijeron que habia que ponerlo aqui
automatic network configuration(DHCP)
conection commands

y nada de nada, me sale "could not get IP addres". No se que es lo que falla. que mala pata. tiene que ser alguna tonteria
por favor si sabes que puede ser le estaré agradecido que me lo comentes. Un saludo

Fallo al seguir el procedimiento arriba indicado

Buenasss,

Soy un linusero un poco novato con Ubuntu instalado y tengo un adaptador Broadcom como el que se hace referencia en este blog. He seguido a rajatabla los primeros pasos, pero al ejecutar:

aptitude install module-assistant build-essential y aptitude install bcm43xx-fwcutter

me ha dado el siguiente error:

enrique@PC-cito:~$ aptitude install module-assistant build-essential
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo información de estado... Hecho
Inicializando el estado de los paquetes... Hecho
Construir la base de datos de etiquetas... Hecho
E: No se pudo abrir el fichero de bloqueo '/var/lib/dpkg/lock' - open (13 Permiso denegado)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
enrique@PC-cito:~$

y no encuentro ninguna manera para poder seguir con el procedimiento que explicas, ni tampoco subsanar el error, ElSanto.

Un conocido mío que sabe algo de Linux me recomendó que renombrar el archivo que contiene los "locks" para así poder eliminarlos, usando sudo mv /var/lib/dpkg/lock /var/lib/dpkg/lock.copia, pero yo creo que al final se ha liado más la cosa.

También leyendo por otros blogs he visto que una solución bastante común a estos problemas suele ser ejecutar apt-get -f install y luego dpkg -- configure -a, pero tampoco soluciona esto mi problema, porque si bien la primera sentencia me vuelve a dar el mismo problema de arriba, la segunda me dice que no tengo privilegios suficientes como para ejecutarla. Así que sigo en las mismas.

Me gustaría que alguien me pudiese echar una mano, porque estoy bastante desesperao.

Muchísimas gracias.

No eres root

Imagen de acl

El problema esta indicado en el mensaje de error, no puedes instalar si no eres root. La solucion es correr el mismo comando con "sudo" al inicio.

Efectivamente tienes que ser

Imagen de ElSanto

Efectivamente tienes que ser root para realizar la instalación, recuerda que cuando veas el simbolo # significa que estas como root, y cuando veas el signo $ es que eres un usuario, en Debian para hacerte root tienes que poner

$ su

En ubuntu tienes que poner sudo delante del comando

$ sudo .......


[FSF Associate Member]

[Linux Counter]

More problemas

Muchísimas gracias por vuestra ayuda. Al anteponer sudo ya me ha dejado, pero al intentar correr el segundo comando

aptitude install bcm43xx-fwcutter

me sale lo siguiente:

enrique@PC-cito:/$ sudo aptitude install bcm43xx-fwcutter
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Construir la base de datos de etiquetas... Hecho
No se instalará, actualizará o eliminará ningún paquete.
0 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 0B de ficheros. Después de desempaquetar se usarán 0B.
Escribiendo información de estado extendido... Hecho
enrique@PC-cito:/$

y por lo que parece no se instala nada. Reiniciola máquina y no me aparece el dispositivo inalámbrico.

¿Sabéis de qué puede ser?

Muchísimas gracias por adelantado.

Prueba primero buscando el

Imagen de ElSanto

Prueba primero buscando el paquete

$ aptitude search bcm43xx-fwcutter

Si te sale algo asi es que lo tienes en los repositorios

i bcm43xx-fwcutter - Utility for extracting Broadcom 43xx firmw
elsanto@debianzv6000:~$

Sino es asi es que creo que en ubuntu tienes que habilitar los repositorios universe(asi creo que se llaman), para que te aparezca...


[FSF Associate Member]

[Linux Counter]

El paquete está en efecto, pero ...

Sí el paquete está, pero al lanzar el install no instala nada:

enrique@PC-cito:~$ aptitude search bcm43xx-fwcutter
i bcm43xx-fwcutter - Utility for extracting Broadcom 43xx firmw
enrique@PC-cito:~$ sudo aptitude install bcm43xx-fwcutter
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Construir la base de datos de etiquetas... Hecho
No se instalará, actualizará o eliminará ningún paquete.
0 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 0B de ficheros. Después de desempaquetar se usarán 0B.
Escribiendo información de estado extendido... Hecho
enrique@PC-cito:~$

No sé que hacer.

Por cierto, ElSanto, he visto también el antiguo post al que te refieres:

"Como hacer funcionar tu BCM4318 AirForce One Single-Chip 802.11g en tu GNU/Linux x86-64"

en el que también das información de cómo instalar este dispositivo inalámbrico en un HP. Allí hablas de cierto driver para ACER. Pues bien mi PC es un ACER AMD Turion de 64. ¿Debería seguir mejor el procedimiento que dabas en aquel post en vez de éste o es este una mejora de aquel?

Muchas gracias

c_rike wrote: Sí el paquete

Imagen de ElSanto
c_rike wrote:
Sí el paquete está, pero al lanzar el install no instala nada:

enrique@PC-cito:~$ aptitude search bcm43xx-fwcutter
i bcm43xx-fwcutter - Utility for extracting Broadcom 43xx firmw

Segun veo que ya lo tienes instalado, la letra i significa que ya lo tienes instalado, ahora solo lo tienes que configurar que es el sguiente paso, ahora espero que no hallas tratado de hacer nada más o otra cosa...


[FSF Associate Member]

[Linux Counter]

No me sale la conexión

Pues aunque parece que como tu dices está instalado, no me aparece la conexión inalámbrica como citas arriba después de reiniciar. Solo me sale la alámbrica y una de módem.

Y tranquilo que estoy siguiendo al pie de la letra cada instrucción que hay en tu post y cada una de las que me estás dando ya que soy un poco novatillo en esto :D

Gracias

eror con el firmware

Hola, yo tambien tengo un problema al correr el comando aptitude install bcm43xx-fwcutter

me dice que "no se encontró ningún paquete con el nombre bcm43xx"

creo que el problema estaba en la instalacion del programa, porque cuando arranco linux desde el live-cd al cargar da este mensaje:
error loading firmware bcm43xx

asi que la pregunta es, como puedo arreglar esto, y por favor una explicacion sencillita, que mi experiencia en linux no va mas alla de intentar instalarlo.
Gracias.

Páginas