AYUDA PARA INSTALAR MODEM LINUX

Imagen de skypower

Lo primero que debemos hacer es como siempre buscar en google por si las moscas, si esto no da resultado nos dirigimos al sitio www.linuxant.com donde mostrara los diferentes tipos de modem que pueden ser compatibles con sus drivers y descargamos un pequeño script que nos dara paso a la instalacion, uno de estos seria cnxtinstall.run el mismo al ser ejecutado pasara un scan a la pc y si su modem es compatible descargara automaticamente los drivers compilara sus modulos y todo saldra bien menos una cosa, la velocidad del modem sera de 14.4kbps y de solo datos porque requieren de licencia.

Ante todo les recomiendo que instalen el linux-headers y build-essential les sera util para las compilaciones:

aptitude install linux-headers-`uname -r` build-essential

Un ejemplo de lo antes dicho seria así


root@debian:/home# ./cnxtinstall.run
Verifying archive integrity... All good.
Uncompressing Linux drivers for Conexant modem chipsets Installer version 1.0.3
Please ensure that all modems are attached to the machine.
Press enter to continue.

Detecting devices in your system... please wait...
Done.

Supported Device Detected
=========================
Name: Communication controller: Rockwell International HCF 56k Data/Fax/Voice/Spkp (w/Handset) Modem
PCI ID: 127A:1005 127A:1005
Needed package: hcfpcimodem

System Information
==================
Distribution: Debian 4.0
Kernel version: 2.6.18-6-686
Kernel architecture: x86

Determining which package(s) to install or update, please wait...
Downloading http://www.linuxant.com/drivers/hcf/full/archive/hcfpcimodem-latest/archive.bz2... 100%

De no funcionar esta via porque no tengamos internet descargamos el paquete completo de nuestro modem y lo instalamos...
Una muestra estos paquetes:
hcfpcimodem_1.17full_i386
hsfmodem_7.68.00.14full_i386

Ya descargado el paquete lo instalamos y al terminar debe estar instalado el modem, no tienen que hacer nada mas...

Un ejemplo de esto seria así

dpkg -i hcfpcimodem_1.17full_i386.deb

Automatically guessed region (using timezone): "PERU"
Unable to unload driver to configure region; modem in use?
try configuring it manually with "AT+GCI=0088"
Setting region for modem unit 0: "PERU"
To change, use "hcfpciconfig --region" or "AT+GCI="
The current region can be displayed by entering "ATI9" in a terminal program.
Current parameters: ("hcfpciconfig --info")

Config for modem unit 0: /dev/ttySHCF0
Device instance: 0-PCI-127a:1005-127a:1005
HW revision : DP Part '71' Rev 'BA' Asic ID 0x215
HW profile name: hcfpciv90
Registration ID: 507E-CDF0-09FD
License owner : unknown
License key : FREE
License status : FREE (max 14.4kbps data only)
Current region : PERU (T.35 code: 0088)

The /dev/modem alias (symlink) points to ttySHCF0

To enable full 56K modem and FAX functionality, enter your license information
with "hcfpciconfig --license".

License owner and key data must EXACTLY match the information respectively
provided to and by Linuxant. Otherwise, license status will remain "FREE"!

Si por casualidad de la vida no conociamos bien el modem y no se instalo porque no era soportado por los drivers que posee linuxant pues le recomendaria otra busqueda mas certera en google y varios post en los foros mas populares de linux, si todavia no resuelves te recomiendo descargar otro pequeño script el cual te ayudara a identificar mejor el modem el cual puede ser descargado desde linmodems.technion.ac.il, es otro buen sitio para empesar despues de haber explorado toda la informacion Linuxant y quemado mucho mas el google... el archivo es scanModem este hara algo parecido a cnxtinstall.run pero creandote una carpeta llamada modem donde guardara una buena cantidad de informacion para que instales tu modem ya sea sitios donde descargar el drivers y los pasos para lograrlo... si todavia no resulves sigue buscando en el google :P .... google

Una luz para los que usan Modem SmartLink...
Pueden compilar el modulo sl-modem el mismo le instalara el modem sin problemas, y para los que no saben compilar modulos usen lo que les mostre al principio build-essential, ademas les mostrare una via rapida:
Compilar e instalar el modulo

module-assistant -f auto-install sl-modem && depmod -a && modprobe slamr && aptitude install sl-modem-daemon && dmesg | grep -i modem && ls -l /dev/modem

Reiniciar el servicio

invoke-rc.d sl-modem-daemon restart

Y para los que todavia no han podido resolver pueden ver estos links:

http://www.linuxant.com/drivers/
ftp://ftp.wizzy.com/pub/wizzy/conexant/
http://linmodems.technion.ac.il
http://phep2.technion.ac.il/linmodems/packages/ltmodem/sv92/
http://www.barrelsoutofbond.org/downloads/martian/
https://svn.kirya.net/listing.php?repname=ltmodem&path=%2Ftags%2F2.6-alk-8-4%2F
http://readlist.com/lists/lists.debian.org/debian-user/29/146932.html
http://mailinglists.linux-de.org/viewtopic.php?t=18256&highlight=driver+lucent+modem

Espero haberlos ayudado...

Salud2s...