Drivers para debian

Forums: 

Hola gente de ecualug.

 Estoy varias horas navegando en Debian :) pero hasta el momento no encuentro los drivers para instalar el audio y el video de mi mainboard Intel D865GBFL... Por otro lado... que suave y sutil corre Debian en la P4 con 512 de ram

(SI ME EQUIVOCO CORRIJANME, SOY UN HUMANO EN VERSIÓN BETA) 

Linux es Libertad!!

 

Cita: Hola gente que pasa

Imagen de RazaMetaL

[quote]Hola gente que pasa con la ayuda!!![/quote]

Pues si nadie responde lo mas probable es que nadie sepa la respuesta.... :(

En mi caso particular dejé de utilizar modems desde hace muuuucho tiempo, y desconozco donde podrías conseguir el módulo apropiado.

Alguna vez utilizé un modem en mi vieja laptop, y el módulo que me sirvió fué el que descargué de [url]http://www.linuxant.com/drivers/[/url]. Pruebalo y avísanos si te sirve, sigue las instrucciones que encuentres en ese sitio web.

------------

Antes de preguntar visita el [url=http://www.sindominio.net/ayuda/preguntas-inteligentes.html]link[/url] :evil:

 

[img]http://www.bbspot.com/Images/News_Features/2003/01/os_quiz/debian.jpg[/img]

-----

Visita este [url=http://www.sindominio.net/ayuda/preguntas-inteligentes.html]link[/url] :evil:

[img]http://www.bbspot.com/Images/News_Features/2003/01/os_quiz/debian.jpg[/img]

(adsbygoogle = window.adsbygoogle || []).push({});

Brother busque en el sitio

Imagen de skypower

Brother busque en el sitio que me indicaste www.linuxant.com y baje un script que monta un asistente para drivers-modem pero este es el resultado que me da...

Pienso que sea porque en la casa no tengo conexion a internet lo que tengo es un Mirror-Debian4!!!


####################################################################################
root@debian:/home# sh cnxtinstall.run
Verifying archive integrity... All good.
Uncompressing Linux drivers for Conexant modem chipsets Installer version 1.0.3

Please ensure that all modems are attached to the machine.
Press enter to continue.

Detecting devices in your system... please wait...
Done.

Supported Device Detected
=========================
Name: Communication controller: Rockwell International HCF 56k Data/Fax/Voice/Sp
kp (w/Handset) Modem
PCI ID: 127A:1005 127A:1005
Needed package: hcfpcimodem

System Information
==================
Distribution: Debian 4.0
Kernel version: 2.6.18-5-686
Kernel architecture: x86

Determining which package(s) to install or update, please wait...
Downloading http://www.linuxant.com/drivers/hcf/full/archive/hcfpcimodem-latest/ archive.bz2... 0%
ERROR: No active Internet connection?

This system doesn't appear to be connected to the Internet. Please use the syste m and device information above to download and install the right package availab le at:

HSF: http://www.linuxant.com/drivers/hsf/full/downloads.php
HCF: http://www.linuxant.com/drivers/hcf/full/downloads.php
DGC: http://www.linuxant.com/drivers/dgc/downloads.php
RIPTIDE: http://www.linuxant.com/drivers/riptide/downloads.php
ALSA driver: http://www.linuxant.com/alsa-driver
####################################################################################
root@debian:/home# sh cnxtinstall.run
Verifying archive integrity... All good.
Uncompressing Linux drivers for Conexant modem chipsets Installer version 1.0.3

If the graphical installer fails to start, you could try the terminal
version that you can start with the following command:

---
sh cnxtinstall.run -- --tty
---

Alternatively, you could manually download and install the packages from the
following pages:

HSF: http://www.linuxant.com/drivers/hsf/full/downloads.php
HCF: http://www.linuxant.com/drivers/hcf/full/downloads.php
DGC: http://www.linuxant.com/drivers/dgc/downloads.php
RIPTIDE: http://www.linuxant.com/drivers/riptide/downloads.php
ALSA driver: http://www.linuxant.com/alsa-driver

Trying to launch a web browser, please wait...

http://127.0.0.1:18021/cgi-bin/setup.cgi

http://www.linuxant.com/drivers/hcf/full/archive/hcfpcimodem-latest/archive.bz2
####################################################################################

ecualug
______________________
!!!AdminRed_Debian!!!

ecualug
______________________
!!!AdminRed_Debian!!!

Necesitas estas conectado a

Imagen de RazaMetaL

Necesitas estas conectado a internet, puedes descargar el paquete .deb desde:

[url]http://www.linuxant.com/drivers/hcf/full/archive/hcfpcimodem-1.17full/hcfpcimodem_1.17full_i386.deb.zip[/url]

------------

Antes de preguntar visita el [url=http://www.sindominio.net/ayuda/preguntas-inteligentes.html]link[/url] :evil:

 

[img]http://www.bbspot.com/Images/News_Features/2003/01/os_quiz/debian.jpg[/img]

-----

Visita este [url=http://www.sindominio.net/ayuda/preguntas-inteligentes.html]link[/url] :evil:

[img]http://www.bbspot.com/Images/News_Features/2003/01/os_quiz/debian.jpg[/img]

(adsbygoogle = window.adsbygoogle || []).push({});

Descarge el paquete que

Imagen de skypower

Descarge el paquete que necesitaba el cnxtinstall.run desde www.linuxant.com y cree un virtual host donde logro encontrar el archivo que me pedia y me mostro esto...

root@debian:/home# sh cnxtinstall.run
Verifying archive integrity... All good.
Uncompressing Linux drivers for Conexant modem chipsets Installer version 1.0.3

Please ensure that all modems are attached to the machine.
Press enter to continue.

Detecting devices in your system... please wait...
Done.

Supported Device Detected
=========================
Name: Communication controller: Rockwell International HCF 56k Data/Fax/Voice/Spkp (w/Handset) Modem
PCI ID: 127A:1005 127A:1005
Needed package: hcfpcimodem

System Information
==================
Distribution: Debian 4.0
Kernel version: 2.6.18-5-686
Kernel architecture: x86

Determining which package(s) to install or update, please wait...
Downloading http://www.linuxant.com/drivers/hcf/full/archive/hcfpcimodem-latest/archive.bz2... 100%

Recommended Action
==================
The following package should be installed: hcfpcimodem

Do you want to install this package ([y]/n)? y

Conexant HCF PCI controllerless driver Installer version 1.0.3
Copyright (c) 2004-2008 Linuxant inc.

ERROR: The generic package is not compatible with this system since kernel
modules can't be compiled. There is also no pre-compiled package
available for your kernel.

Under Linux, the drivers must be compiled for a specific kernel version. This
is a characteristic of the the Linux kernel and not a limitation of Linuxant's
products.

To reduce the inconvenience of this limitation, we offer packages both in
pre-compiled (kernel-specific) and generic variants. We recommend using the
generic version of the package since you will not have to run this installer
again if you upgrade your kernel. The generic packages automatically build
the kernel modules for your system and require the compiler and kernel header
files.

Unfortunately, not all systems are able to compile kernel modules for multiple
reasons. In this case, we offer pre-compiled packages for many kernel versions.
These packages contain kernel modules for each specific kernel and do not
require a compiler nor kernel header files, but you will need to run this
installer again to obtain a new package.

A component required by the generic package is missing on your system. Please
install the 'kernel-headers-2.6.18-5-686' package. You can install it with
the 'apt-get install kernel-headers-2.6.18-5-686' command. Then, try again to
run this installer to use a generic package.

No pre-compiled package is available for your system. This is because you are
either using a custom compiled kernel, or a kernel for which we do not yet
offer pre-compiled packages.

Ahora estoy descargando el paquete que me dijiste para ver si con ese resuelvo...
hcfpcimodem_1.17full_i386.deb.zip

ecualug
______________________
!!!AdminRed_Debian!!!

ecualug
______________________
!!!AdminRed_Debian!!!

Todavia sigue algo igual, da

Imagen de skypower

Todavia sigue algo igual, da problemas con la version del kernel o que me falta instalar un paquete kernel-headers-2.6.18-5-686...


root@debian:/home# dpkg -i hcfpcimodem_1.17full_i386.deb
Seleccionando el paquete hcfpcimodem previamente no seleccionado.
(Leyendo la base de datos ...
116631 ficheros y directorios instalados actualmente.)
Desempaquetando hcfpcimodem (de hcfpcimodem_1.17full_i386.deb) ...
Configurando hcfpcimodem (1.17full) ...
Conexant HCF controllerless PCI modem driver, version 1.17full

If you need license keys, assistance or more information, please go to:
http://www.linuxant.com/

When reporting a problem for the first time, please send
us the file generated by "hcfpciconfig --dumpdiag".

No pre-built modules for: Debian-4.0 linux-2.6.18-5-686 i686-SMP

Trying to automatically build the driver modules...
(this requires a C compiler and proper kernel sources to be installed)
Please install the 'kernel-headers-2.6.18-5-686' package. You can install
it with the 'apt-get install kernel-headers-2.6.18-5-686' command.

WARNING: missing file /usr/src/linux/include/linux/autoconf.h
The cause of this is usually a missing or unconfigured
kernel source tree (and sometimes an incorrect directory or symbolic link).

First, ensure that the proper kernel source and compiler packages
from your distribution vendor and/or the community are installed.

The Linux kernel can then be reconfigured by running "make menuconfig"
under the kernel source directory (usually /usr/src/linux).

Verify that the proper options for your system are selected.

Then compile and install your new kernel (for more information about
this procedure, see the README file under the kernel source directory),
reboot the system using the new kernel, and re-run "hcfpciconfig".

##########################################################################

root@debian:/home# ./cnxtinstall.run
Verifying archive integrity... All good.
Uncompressing Linux drivers for Conexant modem chipsets Installer version 1.0.3

Please ensure that all modems are attached to the machine.
Press enter to continue.

Detecting devices in your system... please wait...
Done.

Supported Device Detected
=========================
Name: Communication controller: Rockwell International HCF 56k Data/Fax/Voice/Spkp (w/Handset) Modem
PCI ID: 127A:1005 127A:1005
Needed package: hcfpcimodem

System Information
==================
Distribution: Debian 4.0
Kernel version: 2.6.18-5-686
Kernel architecture: x86

Determining which package(s) to install or update, please wait...
Downloading http://www.linuxant.com/drivers/hcf/full/archive/hcfpcimodem-latest/archive.bz2... 100%

The following package is already up-to-date: hcfpcimodem

ecualug
______________________
!!!AdminRed_Debian!!!

ecualug
______________________
!!!AdminRed_Debian!!!

Los mensajes de error que te

Imagen de RazaMetaL

Los mensajes de error que te da el instalador son bastante claros. Necesitas conectar tu pc a INternet y descargar los paquetes que te piden, solo un detalle, el paquete kernel-headers cambió su nombre a linux-headers. Si tienes el CD/DVD de instalación de debian puedes buscar el paquete y luego instalarlo, a mi se me hace mas sencillo conectarme a internet y escribir:


aptitude install linux-headers-`uname -r` build-essential

Eso instalará las dependencias necesarias para que puedas hacer funcionar tu modem. Ya la parte mas complidada la tienes resuelta, que era justamente conocer si existe un módulo que haga funcionar tu modem ;)

------------

Antes de preguntar visita el [url=http://www.sindominio.net/ayuda/preguntas-inteligentes.html]link[/url] :evil:

 

[img]http://www.bbspot.com/Images/News_Features/2003/01/os_quiz/debian.jpg[/img]

-----

Visita este [url=http://www.sindominio.net/ayuda/preguntas-inteligentes.html]link[/url] :evil:

[img]http://www.bbspot.com/Images/News_Features/2003/01/os_quiz/debian.jpg[/img]

(adsbygoogle = window.adsbygoogle || []).push({});

Gracias hermano... aqui esta

Imagen de skypower

Gracias hermano... aqui esta todo OK...


root@debian:/home# dpkg -i hcfpcimodem_1.17full_i386.deb

Automatically guessed region (using timezone): "PERU"

Unable to unload driver to configure region; modem in use?
try configuring it manually with "AT+GCI=0088"

Setting region for modem unit 0: "PERU"

To change, use "hcfpciconfig --region" or "AT+GCI="
The current region can be displayed by entering "ATI9" in a terminal program.

Current parameters: ("hcfpciconfig --info")

Config for modem unit 0: /dev/ttySHCF0
Device instance: 0-PCI-127a:1005-127a:1005
HW revision : DP Part '71' Rev 'BA' Asic ID 0x215
HW profile name: hcfpciv90
Registration ID: 507E-CDF0-09FD
License owner : unknown
License key : FREE
License status : FREE (max 14.4kbps data only)
Current region : PERU (T.35 code: 0088)

The /dev/modem alias (symlink) points to ttySHCF0

To enable full 56K modem and FAX functionality, enter your license information
with "hcfpciconfig --license".

License owner and key data must EXACTLY match the information respectively
provided to and by Linuxant. Otherwise, license status will remain "FREE"!

ecualug
______________________
!!!AdminRed_Debian!!!

ecualug
______________________
!!!AdminRed_Debian!!!

Bien, me alegro que ya

Imagen de RazaMetaL

Bien, me alegro que ya funcione. El dispositivo que debes usar en la configuración del acceso telefónico a internet es /dev/ttySHCF0 . Un detalle que debes tener en cuenta es que funcionará a 14400 bps y que para habilitar la velocidad de 56000 debes adquirir una licencia :( Nada es perfecto, pero al menos el mondem funciona ;)

------------

Antes de preguntar visita el [url=http://www.sindominio.net/ayuda/preguntas-inteligentes.html]link[/url] :evil:

 

[img]http://www.bbspot.com/Images/News_Features/2003/01/os_quiz/debian.jpg[/img]

-----

Visita este [url=http://www.sindominio.net/ayuda/preguntas-inteligentes.html]link[/url] :evil:

[img]http://www.bbspot.com/Images/News_Features/2003/01/os_quiz/debian.jpg[/img]

(adsbygoogle = window.adsbygoogle || []).push({});

Correcto brother, el

Imagen de skypower

Correcto brother, el objetivo es que funcionara y eso se logro, es verdad que esta un poco lenta la conexion pero bueno !que se va hacer!, esas son las diferencias entre win y linux...

Salud2s... y gracias...

ecualug
______________________
!!!AdminRed_Debian!!!

ecualug
______________________
!!!AdminRed_Debian!!!

Páginas